How do you stop text from cutting out of the textbox?

I don’t know if this is the correct category, but here’s a video of what I mean.

It goes off of the textbox, how would I stop that from happening? Any properties or do I have to do something in a script?

1 Like

I think you’d have to have TextWrapped property to true, and if that doesn’t work, resize the text when typing too much.

tick ClipDescendants on in the properties of the textbox?

2 Likes

Go to the Text Box’s properties and enable “ClipsDescendants”.

Thanks for answering, and it partially works. It doesn’t go out of the textbox but I can’t see the text past the textbox, basically, if I type “example text example text” it will only show “example text example” and it won’t let me scroll.

1 Like

Thanks, cheesy gave the same answer and I responded to him with my problem.

1 Like

You’ll have to create a system where the textbox grows based on the number of characters that are present

try resizing the textlabel [Chars]

Use text scaled

character limit

As others said you’d have to create a system where it expands based on the text length, you can use TextBounds for this.

See if this property works for you
UI Automatic Size (developer.roblox.com)

1 Like