How to make basepart less bouncy?

hi, i have a sphere as a grenade, and whenever i throw it close to myself it bounces up and down, which i dont want. i have already tried messing with the physical properties but that didnt change anything, so im wondering if its possible to make it less bouncy

have you tried setting elasticity to 0?

1 Like

i have yes, but that didnt change anything

try setting the floor’s elasticity to 0 as well, I just tested in a baseplate and it worked

just tried it, its still bouncy for me

Maybe set the Sphere’s CanCollide property to false? A video could be a bit more helpful explaining how it happens :thinking:

Hmm. I recommend you try increasing density.

Maybe set the density of the grenade to 7

Set the elasticity of the grenade to 0

And set the elasticityWeight of the floor to 0