How to prevent a part from going top of the model while repositioning?

The issue from a gif:

This happens when I change the position of the door part from a script. I use

I tried creating a collision group between the parts of the cabinet but that didn’t fix it. Anyone have a solution for this?


Vector3 is always using collision, you’ll need to set the new position as a CFrame to remove that option.


Okay, well that fixed it for positioning. However, while rotating, I have to use Vector3. Any solution for that? * CFrame.Angles(math.rad(X), math.rad(Y), math.rad(Z))


You should rotate using CFrame.Angles

1 Like

Small correction needed here for people looking at this post in the future.

Setting the position (rather than the CFrame property) is the issue here. It triggers ‘safe move’ behavior which is what may cause a part to appear higher than what you wanted.

The fact that position is a Vector3 isn’t relevant.