[HttpService] Change type of headers parameter to Dictionary

The GetAsync and PostAsync functions both have optional headers parameters. The type can be either Dictionary or nil, hence why they are marked as Variant. While this may make sense, it is rather unclear, and must be clarified with extra documentation.

I propose that the type be changed to Dictionary, and that the parameter have a default value of {}. This makes it more apparent what the actual type is, while also retaining an indication that the parameter is optional.