I need help with Mesh Importer/Surface Appearance

Hi, Recently I made a model and when I imported it into roblox using Mesh Importer instead of it just applying texture like it did couple months ago now it creates Surface Appearance in the model it self and makes the model look ugly, is there any way to make it so that it doesn’t create Surface Appearance?

note: I also sort of found a solution to this but It will take ages to do (apply textures)

Couple months ago:
https://gyazo.com/14a02ef79944928fb985a651e55f8861
Now (using Mesh importer):
https://gyazo.com/27f3b56496535a83acfd01d3d2944f97

1 Like

What is the problem with surface appearance? It is more better if u add white color in metallic map and black color roughness map. U can generate normal map by photopea

i think you’re still able to disable this under beta features, i might be wrong though

and what is that feature called? in beta feature tab?

originally it is supposed to be black the diffuse map already has color and detail but surface appearance ruins it

If you export it as an OBJ file, it should keep the texture on the model when you import it to Roblox

It was for roughness. One way if ur lazy make a plugin to select all surfaceappearance . Get diffuse map . Put it in mesh texture id delete surfaceappearence