ID = 142: Network protocol mismatch. Please upgrade

So I was trying to connect to a game.

What is going on?

It’s connecting fine now…

I haven’t ever gotten a error like that before. Let me go join a game and see if it happens to me.

Edit: didn’t have that problem.

Basically it means that the version of ROBLOX that you’re running or the server is running is different - they’re incompatible.

Like you said, it’s working fine, so it was probably just the one server you were connecting to which was out of date.

Okay, this is actually a big deal. Seems my game has this problem, and not only one server: EVERY server. I got 0 players online right now, and it’s literally never at that point if everything works as it should!

Is ROBLOX undergoing maintenance? This tends to be the most common error when such process is going on.

Other games work fine