I'm lagging so much in every ROBLOX game I play (2,800 Ping!) Help!

lag
connectivity

#1

To describe the issue, I have an incredibly high ping whenever I play games on ROBLOX. it goes up to 400 when I am in an empty baseplate essentially. However, when I play the games themselves, like Phantom Forces or Counter Blox: Remastered, I get horrible lag that keeps stuttering every 5 seconds and people just teleport everywhere. Totally taints the game experience

This issue occurs for me every time I play ROBLOX. Yes, I have already tried different internet connections in different households and it all yields the same result, regardless of connectivity strength.
I do not have this issue on any other websites or video games either, so it HAS to be a Roblox problem

The bug happens in every ROBLOX game I play, so I don’t know how to fix this

Lag

System Specs:
Processor: Intel® Core i7-7820HK @ 2.90 GHz
Graphics Card: NVIDIA GeForce GTX 1070
RAM: 24 GB DDR4

This bug really started happening out of nowhere I think. I don’t recall having any issues right after a recent ROBLOX update. Please, I need a solution soon! New ROBLOX updates don’t really seem to fix it and I can’t test out any of my games that I’m working on, and it sucks!


#2

Do you use ethernet or wifi?


#3

This is probably to do with your internet


#4

do you mean teleporting like this?


#5

I use WiFi, but I always have and I never have had any issues prior


#6

Yes, teleporting behaving just like that


#7

This is a longshot, but… Have you ever tweaked with the IncomingReplicationLag value in Roblox Studio’s settings?

Like 2 years I ago I was using it to simulate high ping games and forgot to set it back to 0, for the next 3 weeks I could not figure out for the life of me why I couldn’t play any games on Roblox


#8

Yeah, the value is already at 0 so I’m not entirely sure if that is the issue


#10

has this problem been resolved?


#11

I don’t know about bluay’s issue, but I know for my game (found here: https://www.roblox.com/games/598947721/HCBB-9v9#!/game-instances) there is like a random chance (seems like 2 out of 5 joins for me) when you join a server, you are going to have the issue as shown in the video I posted on this thread. Where the ping just jumps all over the place. You can attempt to fix the issue by rejoining the same server using the teleport service, but then again, this only works 2/5 of the time.


#12

No, it is not resolved


#13

can you send me the IP address of the server the game is running on? it should be in the logs


#14

How do I retrieve the server IP?


#15

I have had similar problems playing a game from home when a new wireless router is set up in the neighborhood. if the 2 routers pick the same frequency they interfere with each other. Even though other network services seem to work fine, this still may interfere with game play. you can try resetting your wireless router and see if it picks another frequency. generally the default is for a random choice, if you have set a particular frequency in the router set up you may want to try another.
please let me know if you have already tried this or if it helps


#16

I tried resetting and nothing could be done to help. I noticed that this only seems to be a problem on my laptop, because my desktop runs ROBLOX just fine with little lag. Is there any way to be able to fix this issue on the laptop? I don’t understand why ROBLOX would be running with such terrible connection when literally every other game on there non-roblox related runs with perfect connection


#17

Is your firewall interfering with ROBLOX?


#18

A firewall would block all network activity with that IP. This is just a slowdown.


#19

I tried to disable the firewall and check how ROBLOX performs, still performs terribly regardless!


#20

I recently had a problem with high ping and meshes/parts/unions never ever loading. Turns out the fire wall had the ports blocked listed Here.
Do you think this could be your problem. Because as soon as I made an exception in the Inbound-Outbound rules games instantly load and I constantly get anywhere from 60-200 ping compared to the 1000+ I was getting.