Is making a Module for Systems and suchlike 100% necessary?

That’s just a bit messy, but can be done, I suppose, I did think of that, it’s just… Messy, but do-able.


Exactly, so having the Module on both sides would be pointless, it would have to be in a Server Container (e.g., ServerStorage) Server, but that’s not entirely relevant right now.

We would still need to use a RemoteEvent to set a Value when requested from the Client. So you see what I mean now, right? No matter if we use a Module for this system or a regular Server Script, we would still have to use a RemoteEvent to set a Value (when requested from the Client). But the whole reason for this post was; What is the difference? Both ways require you to use a RemoteEvent (when requested on the Client x2). Unfortunately, some Values HAVE to be set as requested by the Client.


Again… As for the rest of your reply, I’ll keep it in mind for now, I haven’t fully read it as first of all, it’s confusing, and it’s a lot… I’ll edit this reply or make a new one once I fully read it with answers.

Thank you for your feedback, much appreciated! :slight_smile:

basically, i prioritize readability over maintainability most of the time. the mindset at the very top of the tech industry is to prioritize maintainability over everything, because of how volatile the top end of that industry can be. this mindset trickles down all the way to hobbyist developers and often in ways that don’t really make sense. take this bit of code from roblox’s legacy chat system for example, it’s a function block that i copied and pasted into an empty script:


not very obvious as to what it does, is it? especially in isolation with all those orange underlines. my understanding is that this function basically does little more than create a textlabel through dozens of other proxy functions, but you wouldn’t know unless you dug around the code for several minutes. the code is written in the safe, object-oriented, industry approved way, but it looks ridiculous and incomprehensible for its purpose. this is what i was talking about when i jokingly came up with the STFU (shut the frick up) principle as opposed to the DRY (don’t repeat yourself) principle: stop typing so much and just write the code that needs to go there without all the boilerplate, you don’t work at NASA.

I see thank you.


You don’t need to be rude about this at all, that’s so uncalled for, seriously. I wanted some help and feedback on a thought I’ve had for a while, there’s nothing wrong in that. I have some nice feedback from nice and helpful people, so I really appreciate that!

I’m going to see what I can gather from this and work it out.

This post was a request for assistance and support, not an argument.

that wasn’t rude or argumentative but whatever