Issue - having problems with my replay system

So, it’s pretty simple - it gathers all parts from Workspace, clones them to a ViewportFrame, detects/saves movement of real parts and applies them to the ones that are being rendered in the replay.

I can’t seem to make the Replay() function work. There are no errors, but it’s unfunctional.

Does anyone have any ideas or suggestions how that could get resolved? Thanks!

Instead do

local UI = game.Players.LocalPlayer.PlayerGui:FindFirstChild("VAR system")

It’s not that. It’s the Replay() function.

Still not resolved, any help is appreciated.

Ah ok, could you tell me where it stops printing?

As you can see, I put several prints in the Replay() function to check its functionality. However, it provides no feedback nor errors. So basically, the whole Replay() function itself.

ipairs can’t detect dictionaries that don’t have numbered indexes. for that, you’d probably want pairs.


This is a local script right???

Yes, it’s a local script.

Still not functional.

can you place a print inside each pairs loop in replay and see if anything prints? whether it be like #CFrameInfo or #instances or anything?