Issue with module scripts, tables, and async


So I tried making a webhook API so that I can send a script to a module and it sends it rather than having long tables in my scripts. However, when I send the table to my module script it returns the values with nil values, and still does it after to string and I can’t figure out why.

Adding on to this the only returned error is this

local webhook = require(game.ServerScriptService.WebhookModule){url='', content = 'lol'})

Won’t make a difference, you can use {} instead of () after a function.

prove it kiddo. why are you using : im pretty sure its not a method

From what a friend of mine has stated

You are using a colon, instead of a dot for your function

Don’t think it’s an issue as it’s a function bit like :FindFirstChild is a function but i’ll give it a look over and try it with a dot.

Just as I thought, I used a dot and the same error occured, the colon and dot can be used interchangeably.

Just as I said above, you can use a colon or a dot.

what if x is already the table. your adding a table into a table and maybe thats issue idk

Hm, don’t think it should be an issue but I’ll change the x in the function to be argument and remove the local line and have a look.

Yep, that was the issue, I don’t have a clue why I didn’t spot that sooner lol.