Issue with two of the same mesh textures have two different color tones

Alright, this is probably a simple issue but I haven’t figured it out. Anyway, I made two mesh roads in blender. Both are the same size but different shape. I did this because I cannot import one huge road thanks to Roblox’s 10k poly limit so I decided to go modular.

I imported both the textures into Roblox and scaled them precisely. I decided to use PBR textures and when I applied them to both meshes I get this result:

I get this weird two-tone effect. The goal was to have the colors be identical. I tried using an MTL to fix this but it has the same effect. To make the mesh and apply the textures I just did a UV unwrap.

I think it could just be a sizing issue however the way blender does the UV mapping should have allowed the MTL format to work.

Please help!


When I zoom out the textures seem to blend in better. I’m not sure if this is an engine bug or if it’s just a sizing issue.

Update 2:
Found out that the problem had to do with texture resizing. I currently do not have a fix for this. I am thinking that I can cut the mesh into multiple pieces then export them individually. The only thing is I do not know how to do that. The other fix I was thinking of was recoloring the texture but I don’t think it’s possible to do that.


SOLUTION: This isn’t an issue with the mesh but it is an issue with the way Roblox lighting and textures render. I believe this is an engine bug and will be making a report soon.

Update: This most likely isn’t an engine bug. However, this is an issue with the way light hits a mesh. Currently, I’m not sure how to fix it.

SOLUTION: Finally found the solution. This simply had to do with a setting in Blender when I exported my .OBJ . I believe it had to do with the UV and the Material Grouping setting. I was able to fix this with by uploading my mesh as an .FBX file. Though FBX is mainly meant for animations to my knowledge it did seem to fix the color issue.

Photo of the final product:

With a little bit of tampering, you can resize the texture to fit properly or you can just make your meshes a similar size to avoid this issue in the first place. It also helps to use the same file type when you export the mesh. I hope this helps anyone who had the same issue. :smiley:

1 Like