Issues with Animation, Doesn't work when standing still only while moving?

I’ve made an animation which only works while moving, the priority is Action. Doesn’t work when jumping either. So basically either one of the WASD Keys have to be pressed for the animation to work. Any clues why I can’t seem to figure out where the problem lies. Here is the script:

local Abilities = {}

function Abilities.Tornado(player)
	local TornadoClone = game:GetService("ReplicatedStorage").DamageSkills.Tornado:Clone()
	
	TornadoClone.Parent = player.Character
	TornadoClone.CFrame = player.Character.LowerTorso.CFrame
	
	TornadoClone.Weld.Part0 = player.Character.LowerTorso
	TornadoClone.Weld.Part1 = TornadoClone
	
	local Animation = player.Character.Humanoid.Animator:LoadAnimation(TornadoClone.Animation)
	Animation.Looped = true
	
	Animation:Play()
	
	
	
	
end


return Abilities

Could we see the script that activates the Tornado function? That might be 1 case if you’re using UserInputService on the local standpoint

if Input.KeyCode == Enum.KeyCode.E then
		
		-- Damage
		script.Parent.Damage:TweenSize(UDim2.new(.26, 0, .842,4, 0), Enum.EasingDirection.In, Enum.EasingStyle.Quint, .05, true, nil)
		wait(.05)
		script.Parent.Damage:TweenSize(UDim2.new(.279, 0, .904, 0), Enum.EasingDirection.In, Enum.EasingStyle.Quint, .05, true, nil)
		
		game:GetService("ReplicatedStorage").RemoteEvents.Damage:FireServer()
		
		print("Damage")
		
	end

Then to ServerScript

RepStorage.RemoteEvents.Damage.OnServerEvent:Connect(function(player)
	
	local DamageSkill = player.EquippedFolder.EquippedDamage.Value
	
	AbilityModule[DamageSkill](player)
	
	
	
end)

Weird, I don’t see anything wrong with the code at all

Maybe you could try changing the Animator's default walk & idle ID’s instead?

I figured it out, but it wasn’t anything with the code, but it worked to make the extra clone into an accessory, and changing the weld to weld constraint. Idk why it worked tho, maybe you have an explanation.

Really? Strange, maybe the TornadoClone was some sort of that Part that apparently only affects your animation when you stop or jump due to physics? I have no clue, it might be because of changing the Weld to a WeldConstriant, but at least you got it fixed though!

1 Like

Mark that as a solution (your post) so it doesn’t show up in unsolved