Left-Handed tool disappearing

I am trying to make a left-handed tool. In this case, I just transferred the grip over to the left hand. This, however, causes the tool to disappear from the inventory after three seconds. I have no idea why.

local animationID = 4875553928

-------------- Do Not Touch Below This Line ---------------
local tool = script.Parent
local plr = game.Players.LocalPlayer

local anim = Instance.new("Animation")
anim.AnimationId = "rbxassetid://" .. animationID

repeat wait() until plr.Character.Humanoid

local loadedAnimation = plr.Character.Humanoid:LoadAnimation(anim)

tool.Equipped:Connect(function()
	print(1)
	loadedAnimation:Play()
	
	local handle = script.Parent.Handle
	--handle.Transparency = 1
	
	local grip = tool.Parent["Right Arm"]:WaitForChild("RightGrip")
	grip.Parent = tool.Parent["Left Arm"]
	grip.Name = "LeftGrip"
	grip.Part0 = grip.Parent
	
	
end)

tool.Unequipped:Connect(function()
	print(2)
	loadedAnimation:Stop()
end)

Any help would be appreciated. Thanks.

2 Likes

Its probably not welded properly so the handle falls through the ground and gets deleted

That is what I was thinking but I don’t know what would be wrong with it. May be because I am doing it locally but I am unsure.

ur not setting a part1 for the grip weld

grip.Part1 = tool.Parent[“Left Arm”]

I just tested that with the handle of the tool and it still didn’t work. It shouldn’t be that problem anyways as I am stealing the grip from the right hand.

try grip.Part1 = tool.Parent[“Left Arm”]

Maybe the grip.Part0 for the right hand is the right arm so your making both part0 and part1 the grip when you switch it over

That didn’t work. I also added a Part1 connection to the handle after I tried yours and that didn’t work as well.

grip.Part0 = grip.Parent
grip.Part1 = handle

Fixed the issue. It was because I was trying to weld the part locally rather than server sided. It was falling into the void. I just made it work server-sided with a remote event.

1 Like

Can you show me the code for that? I ran into the same problem and I don’t understand how you would transfer it to the server