Mesh not updating after fix

I’ve been modeling recently, I’m still new and encountered a problem.

I cant seem to update a mesh part to the model I want, as it will still update to the other meshes. When I first tried to change the mesh part I was prompted with ‘Too many triangles’, so I went back to blender and did ‘limited dissolve’ on the model. I still get the prompt to add it and everything but to no prevail.
I’ve lowered triangle count with multiple methods, changed the save file, restarted studio, and am now asking for help.
What is the problem here? Any suggestions?


How many tris in the Mesh?
A cup like that probably doesn’t need more than 200 or so. The more tris, the more your game will be slowed down while they render.
Also with less tris use the Smooth Faces tool to round out the corners between faces.

Its not a lag problem, game runs smoothly on max settings with meshes that have high triangle count. But currently I got it down to 5000+ Triangles… still learning.

My guess is that it moved to another location, is the meshpart still in the workspace?

It never moves, stays in the same spot and still stays in the workspace. (Also tri count is now under 3k)