MeshPart not getting inserted

  1. Importing a mesh doesn’t work.

  2. When I try to insert a mesh it is doing nothing, my account could be restricted but when I try to insert it in a offline studio it isn’t working.

  3. I tried to open it in a program on windows and the mesh was showed like how it is.

Thanks for helping.


I don’t use studio offline ever but could it not just be that meshes can’t be imported offline because you need an online connection?
Maybe its an issue with the mesh itself?

I don’t know why but the mesh looks good I think, I firstly tried in a online session that didn’t work. Thats why I am asking here thanks for your reply :wink: !

the image is from 3D-viewer.

Did you get it from the 3D viewer because I’m pretty sure that won’t work. If you’re looking to import your own asset then you should build one in an external software like Blender or Maya and the file type matters as well (like OBJ.) and you would also have to texture this asset.

I think perhaps the issue is that it’s taken from the 3D viewer. If you’re interested in making it or fixing this issue you could try to make it in blender, texture it then upload it to roblox. If you’re stuck follow a tutorial.
I hope this helped

I opened it in 3D viewer so I firstly used Blender to build it after I exported the model from Blender as a obj/fbx file. I use no texture on it(wasn’t done yet wanted to see the look)

Try it in online mode, I’m not familiar with offline

1 Like

I tried and it still doesn’t work. Just took a look in output(since I tought to take a look there but roblox is tsaying that the name is inappropriate the file was called “borden”). Thanks for your help, this topic is solved.