"MorphHead is not a valid member of model" except its there

So im having this issue where, I have this morph I am making, and I wanted it to execute a function whenever I said something in chat, however, whenever I try it, it gives me a “MorphHead is not a valid member of Model.PeterCreates” when its actually there. I don’t know what to do anymore, I tried renaming it, using variables on it, etc. Here’s the line of code


and here’s the model :

and yes, whenever I morph into it, it goes to my character, here :

You could try using :WaitForChild("TheHead") instead of FindFirstChild, what might be happening is that this code runs before that instance is actually cloned over to your character.


I tried that before, altho it didn’t work, im gonna try it again, maybe I did something wrong when I did try it.

It still did not work, but I found out something


this is an error popping up on the script, does this have anything to do with it not working, if so, how would I fix it?

I already fixed this and it still won’t work, since the previous issue was the fact “TheHead” was given as null, im assuming it’s waiting on forever and it’s not showing up

here’s a screenshot of how it currently looks


and as you’ve seen, “TheHead” is actually on the character, im not sure what is causing this but apparently the head thingy is being completely ignored.

Yeah I see what’s happening.

Basically, you’re yielding for TheHead to exist, so your chatted event should theoretically never run since the script yields forever.

Perhaps if you removed your reference variable to ‘TheHead’, and used it only when you know it’ll exist, then maybe that’ll give you some success. However, you’ll probably still want to use WaitForChild since remotes do have a bit of a delay (ping)

Oh okay! let me try it real quick

wait so you mean remove the variable and use the “TheHead” instead of a variable?

Just get rid of it at the top, and try to index it from the character when ever you actually need to do something with it.

I did, and still nothing is happening, im suspecting its on the server event scripts.

here’s how they look :


The other one looks the same except adjusted for the function, and yes I used bool values here.

print out this:

To see if your model “TheHead” actually exists inside the player

Thats the thing tho, I did check if it existed in player.Character


that was one of the screenshots in the first post, look closely “TheHead” is there