Motor 6D not working

  1. What do you want to achieve? Keep it simple and clear!

Animate my sword

  1. What is the issue? Include screenshots / videos if possible!

The Motor6D isn’t moving the sword is acting strangely


  1. What solutions have you tried so far? Did you look for solutions on the Developer Hub?
    I looked for solutions on the devforum, but they weren’t able to help. I asked a discord server but no one has responded yet.

After that, you should include more details if you have any. Try to make your topic as descriptive as possible, so that it’s easier for people to help you!

I believe that the client is playing animations before the motor is created, I wouls edit the code in the local script to do wait for child for the motor before playing the animation

1 Like

I don’t think that’s why, I put a wait after firing the remote. The sword still doesn’t animate.

Can you check if the Motor6D’s active property is true? If not, it is probably because of the other Tool weld that roblox automatically puts

I found the solution, my friend told me I have to make the name of the sword I animate the exact same as the sword I replicate :+1:t5:

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.