Mouse icon not changing

On my first test in Studio, it gives “Request Failed” error but when I stop and play the game again, it no longer gives that error but this time mouse icon disappears.

It doesn’t get content deleted.

I tried in 650x650, 64x64, 10x10, 50x50 and none of them worked.

I’m using a LocalScript.

local player = game.Players.LocalPlayer
local mouse = player:GetMouse()
local tool = script.Parent

	mouse.Icon = ""

Hey there!
Have you tried using the rbxassetid:// version? For you it will be
mouse.Icon = "rbxassetid://4989835598"
Please try changing it and get back to me with your results.

I personally tried using @MegaBorecYT’s method, but it didn’t work.

Try this Asset Id if it doesn’t work for you:

Hope this helped!

Also, thanks MegaBorecYT for giving me that testing link. :slight_smile:

1 Like

Yeah, I just noticed, @Gnen_Steve has "" where it should be “” (as you typed). I think this will solve this problem :slight_smile:

Yep, just needed that /. :slight_smile:

Thanks everyone!

@MaximussDev What was the difference between these two?

Nothing really, just that rbxassetid://_____ doesn’t always load in my experience. I believe (take this with a grain of salt) that rbxassetid://_____ came out wayyy before the method. Again, I’m not 100% sure, though.

1 Like

It was too big than I expected so I uploaded a new decal and it’s ID is 4990184461 but when I replace the ID with this, same error happens again.

Just put “4990184461” into the Image property on an ImageLabel, press Enter, click on the Image property and copy it. Then, set it into the script.


Sorry for too many questions but what is the ID of default cursor?

Just look through your Roblox File, and say, “rbxasset://textures/ui/[find mouse icon and copy/paste name here].png”