Multiple Tools in Roblox Studio Broken when Any Plugin is Enabled

As of lately, multiple tools in studio are broken when I have any plugin enabled. The pieces that are broken when this happens are unblurred below.

When clicking on any of the tools, they toggle on and off but don’t do anything. The tools all work if you open studio with no plugins enabled but enable them while studio is open. Additionally, when this occurs none of Roblox’s built in plugins load.


I first personally experienced this bug when I opened studio last night, though I hadn’t opened studio in a while and it seems to have been experiencing for some people as of a few days ago. This bug seems to not be affecting most studio users, however more than just myself seem to have been affected at the same time.

To reproduce this bug (only if you are affected by it):

  1. Open studio
  2. Enable any plugin, it doesn’t seem to matter what plugin you enable
  3. Close and reopen studio
  4. All of the broken behavior described above should be present

As this bug doesn’t affect everyone and only a small number of people it seems, there’s likely more info that I’ll need to provide and will do so upon request. However, here’s my current version of studio. I’ve tried different places as well as uninstalling and reinstalling studio.


Edit: It seems this behavior only happens if you launch studio from the create page on your browser. If you open studio on your computer and load the place file from there, the issues won’t occur.



Several of us are looking into this, but even following the steps you have provided we are not able to reproduce. We have opened studio from the create page on Firefox, Safari and Chrome, and we can’t encounter this issue. Any more information is greatly appreciated.


The problem is that’s all it takes to reproduce the bug for me and I assume experiencing it. A lot of people seem to be fine, as I’ve had a friend follow the same steps but he’s unable to reproduce the behavior at all. Reinstalling studio did not fix for me, apparently it has for some others but I’m really unsure why.

Edit: I just saved place file to my computer and opened the file directly and it seems to work fine, so it has to be from a browser it seems. Happens from Firefox, Chrome and Edge for me, never tested any other browsers and confirmed just now that it’s still happening.

1 Like

Can you please include your log file from a Studio session where this happened? Send it privately to Logs / Crash Dumps / Other Bug Files.

1 Like

Actually, I just reproduced this by closing all of my open plugin widgets.

This seems to reproduce reliably when I close all of my plugin widgets so none are opened by default, and open a place from via this little Edit button on Chrome. This does not happen if I have any user plugin widgets opened by default (e.g. Xaxa’s brushtool, or the tag editor enabled such that the widget opens when Studio loads a place).


Log file is here:


I can agree with this statement; It always happens whenever I close/disable all my plugins from the “Plugin Tab” where you disable all the plugins and for me to fix it. Another thing is whenever I disable any “camera” plugins, my cursor whenever I press right-click it glitchy and bugs out.

it happened to me when I created a new file in studio using the File > New, button, only with plugins enabled, if i disable all of them it stops

I wasn’t initially going to comment on this post because I don’t have anything useful to add, but I feel the need to state that this is still happening and has been a big issue for me all week long. I can work around it by opening up a saved file from my computer, but this disrupts my normal workflow. I need to keep plugins enabled as well, so disabling all of them in order to prevent this issue is not really an option for me.


This is also happening to me, regardless of whether a plugin is turned on and off, I cannot select, move, scale, or rotate anything when I open a certain place via the website Edit button. Other places I open with the website turn out to be fine with no issues. The issue does stop when I open the place via the desktop application.


Yeah getting a problem with tools also not sure if it’s plugin related. Opening old save files doesn’t cause this bug for me, but when I open a new place file I can’t seem to select anything in the game world. I can also highlight all my tools at once:

I’ve been opening a new file via an exisiting place with the new file button on the top left or (CTRL+N).


I’m having the same problem with the tools and toolbox and it started a week ago, yeah I can’t update my game if I cant even use the basic tools. Yall noticed this happened a week ago Also some of my basic roblox plugins like the align tool disappeared.

Nvm I just fixed my studio by just reopening it 3 times. :smiley:


I just can’t at this point… I got a fairly decent community & trying to update my games… I hop into studio & I don’t have access to any of the tools. I also closed & reopened studio more then 20+ times yet nothing. What in the world is going on lol, I have some dev work :confused:

Edit: Tried for 5 more times straight, it’s back to normal. It worries me that I’ll still face this problem AFTER I’m done & close my studio.


Try disabling all of your plugins and restart studio, that’s what I’ve been doing. I hope that this issue will be resolved soon since it’s affecting my developing time.

For me it just happens, even when no plugin is active, it happens mostly as he said, by opening a place from the website or browser. This bug sometimes happens by opening a place in studio but is rare. The bug is not letting me build since last month in my main place because of that bug. (It doesn’t require steps to reproduce the bug) a bug is something that happens without you expecting it, I just know that the RobloxPluginGuiService is literally empty. For the reason the other stuff ain’t opening.

1- I think there is something that is not letting the Roblox’s Guis load properly. (Idk what it is)

Sadly I’ve been having this same problem and it has become quite annoying. I’ll simply open studio for the Web Page and as stated I can’t move or rotate anything. I can still select stuff in workspace however I can’t select anything threw the viewport. opening it with the App seems to have fixed it for me and it doesn’t seem to happen on new files.


I’ve been experiencing this too, it also makes it to where Toolbox doesn’t open as well so I have to close and reopen studio 2 or 3 times to get stuff to work.


For me usage of the lock tool allows that to operate, but upon selecting the other tools or making an effort to do so I get the same result as @ChickenEngineer.

I will be programming in one file, open up another to inspect a build and have this happen.

I will be building in a team create, and that is fine, but upon opening another published but personal place have this happen as well.

I have not explored how it effects tools for locally saved files or attempted to fix via disabling my plugins.


I have the same problem! When I press the edit button, the Roblox Studio is break too, I need to Reinstalling studio to fix the problem :frowning:

I’ve been having this problem too. I had to disable all my plugins :electric_plug: :sad:

I emailed Roblox Support, but they didn’t help.


the same things happen to me when i open roblox studio via web now i open it via the app

1 Like