My Dash system: Why is that happening?

Hello everyone, I have problems with my animation.

What do I want achieve?

I am creating right now a BodyVelocity but I have animations problems.
I setted my animation to Movement but that is now what is happening:

https://streamable.com/ajc9mu

How can I fix this?

You can set it to action as well but also make sure that every part of the animation is animated like the upper legs and such as otherwise they become prone to roblox physics

1 Like

I am trying everything but it still does not working

I Seriously dont know what the problem is   

     local RunService = game:GetService("RunService")
        local Players = game:GetService("Players").LocalPlayer
        local Humanoid = Players.Character:WaitForChild("Humanoid")
        local HMRP = Players.Character:WaitForChild("HumanoidRootPart")
        local RightDash = script:WaitForChild("RightDash")
        local LeftDash = script:WaitForChild("LeftDash")
        local Rightanim = Humanoid:LoadAnimation(RightDash)
        local Leftanim = Humanoid:LoadAnimation(LeftDash)

        local function Dash(studs, look)
        	local BodyVelocity = Instance.new("BodyVelocity")
        	BodyVelocity.MaxForce = Vector3.new(10000,1,10000) 
        	BodyVelocity.Velocity = studs * look
        	BodyVelocity.Parent = HMRP
        	wait(1)
        	table.foreach(Players.Character:GetDescendants(),function(i,v)if v:IsA("AnimationTrack") then v:Play() end end)
        	BodyVelocity:Destroy()
        end


  RunService.RenderStepped:Connect(function(player)
	if Properties.pressQ == true then   
		print("Right")
		if Leftanim.IsPlaying then
			Leftanim:Stop()
		end
		if not Rightanim.IsPlaying then
			table.foreach(Players.Character:GetDescendants(),function(i,v)if v:IsA("AnimationTrack") then v:Stop() end end)
			Rightanim:Play()
		end
		Dash(Humanoid.MoveDirection, 50)
		Properties.pressQ = false
	end
end)

do this

-- When Animation is playing
char.Animate.Disabled = true

-- After the Animation Ended, Do this-
char.Animate.Disabled = false

1 Like

still it does move the feets. I just want stop everything :confused:

Maybe I have to set the walkspeed to 0

Do you have any other ideas cuz I dont want animate anything of the humanoid legs (it will look not so cool)

Roblox Studio Engine has physics sometimes bugs. How can I report this issue to Roblox cuz this should work and end the animation:

table.foreach(Players.Character:GetDescendants(),function(i,v)if v:IsA(“AnimationTrack”) then v:Stop() end end)

This not a issue with roblox, it’s an issue with your animation.
You have make sure all limbs are animated.
image
And in your case, it’s being simulated by Roblox’s physics.


You don’t have to move the legs. You just have to insert a keyframe so that it won’t be simulated by Roblox’s physics.

okey let me try. I am not sure how I can insert a keyframe. But it would be still good if Roblox fix this with the Animation or not?

It is not their fault.
Roblox’s physics are always being simulated, therefore if you animated something but didn’t animate the legs/feet, it would be simulated. And addition, you should set priority to action so that the Idle animation won’t get in the way of the Dash animation.

1 Like

have u tried setting the animation priority to movement…?

1 Like

Nop action and movement didnt work too

Are you using Moon Animator or Roblox's default animation system?

1 Like

Can you show me with screenshots what you mean with “insert a keyframe”

and without moving the bodypart

Are you using Moon Animator or Roblox's default animation system ?

I am using Roblox defaults animation.

I tried what you saying but it still doesnt seem working

Here is a gif.
https://gyazo.com/2a74274987291af2425258a4a8383967

1 Like

oh okey really thanks let me test it

1 Like