My function somehow "explodes" my car when it runs, unintentionally

So, in one part of my car script i have it so that if you touch the body of the car, it forces you to sit. That function has worked perfectly until now. Now when the function is ran, (when i touch the body) it goes SAILING through the skys, and for some reason it doesn’t come back down, (its unanchored)
Here is a video, and after that I’ll show my script, and tell me if you want more info on how my car works so you can help solve it.

local function PartTouched(part)--function that i belive is not working
	if (seat.Occupant or cooldown ~= 0) then return end
	local character = part.Parent
	
	local player = game.Players:GetPlayerFromCharacter(character)
	if (not player)then return end
	local Humanoid = character:FindFirstChild("Humanoid")
	if (not Humanoid)then return end
	
	seat:Sit(Humanoid)
	occupiedPlayer = player
	CharCollide(character, false)
	car.PrimaryPart:SetNetworkOwner(player)
 	OccupiedClientScript = CarClient:Clone()
	OccupiedClientScript.Car.Value = car
	OccupiedClientScript.Parent = player.Backpack
	CoolDown(1)
end
local function Occupantchange()--Not imporant
	if (seat.Occupant) then return end
	if (occupiedPlayer == nil) then return end
	if (occupiedPlayer.Character) then
		CharCollide(occupiedPlayer.Character, true)	
	end
	if (OccupiedClientScript == nil) then return end
	if (OccupiedClientScript.Parent)then
		OccupiedClientScript.Stop.Value = true
		local client = OccupiedClientScript
		delay(3,function()
			client:Destroy()
		end)
	end
	car.PrimaryPart:SetNetworkOwnershipAuto()
	occupiedPlayer = nil
	OccupiedClientScript = nil
	CoolDown(3)
end

Body.Touched:Connect(PartTouched)
seat:GetPropertyChangedSignal("Occupant"):Connect(Occupantchange)--Not imporant

Its pretty weird, I do have a script that makes it drive, and messes with some constraints so it can drive, if you want to see that script or anything else. Please say so.

There is an error in the output. What is it?

You can’t set the NetworkOwnership inside BaseParts that have the Anchored property set to true (Or other BaseParts that are welded & Anchored)

Try unanchoring all the parts inside the car to see if that makes any difference

Its this line and another one:

car.PrimaryPart:SetNetworkOwnershipAuto()

its because i had it anchored so i can show you guys, and its not suppose to, but when i unanchored it does the same but the car pieces goes father so you can’ see the car anymore.

Yeah, i didn’t explain it well, i did that to try to show you how it looks like, when i unanchored it, (how it is suppose to be) all the parts go wayyy farther. Which is weird because i don’t think its a physics problem because all the other parts in the map aren’t behaving like that. But if it was a scripting issue it would also be weird since i didn’t really mess with anything except for the cylincdrical constraints that are attached to the car

And whats also really odd, is that it worked perfectly like 3 hours prior but when i came back to finalize it, it started behaving like that.