My legs wont move in my animations i'm making

Hello Developers,

So, I am making an animation. But for some reason everytime you execute the animation your legs don’t move. If your thinking, “theres many topics on this already.” Well I read those, and they said set the animation priority to ‘action’ I did that, and it still doesn’t work.

I was wondering if anyone could help or relate.

It would help if you stated more than “your legs don’t move”. Maybe show a video of the movement issue with the animation controller visible.
Are your joints in a custom rig, or the standard Roblox rig?
When you say “execute the animation” do you mean in Studio Test mode, or the animation controller, or in your game?
Is the animation controlling just the legs, or the entire rig?
We don’t need some info, we need all the info.

Make sure you put keyframes for ALL the leg parts at the beginning and end

2 Likes

When I mean execute, I mean by:

I have a keybind animation script. When you click (keybind) then it plays the animation. But the legs aren’t moving went I walk with the animation.

Oh, I tried what you just said and it worked. Thank you so much!

No problem. Glad I could help.