My Ovoid Shaped Custom Character Won't Animate

So I was just playing around in studio and I keep running into this issue where my character will not animate. My character also can’t detect plastic, so I wasn’t able to jump over that material which is weird, but probably has to do with its ovoid like shape. So far I just have a walking animation, so I am not certain this is with every animation.

Here is a video for a better understanding and visual perspective of what I mean.

I am using the R6 version of the Animation script because my model is an R6 type, I tried putting the id in the values that are parented to the script. I tried deleting the values in the script and I remade the whole animation, but still nothing. I did look online to see what I could find, but I was stumped I couldn’t find anything.

All help is very appreciated! Thanks! :smile:

Some good news! I was able to fix the jumping problem by making every part non-collidable and changing the hip height a bit. Seems like a weird fix to do, so if anyone else knows a better fix it would be great to hear. Still sadly having issues with the animations. I did make a jumping animation and that doesn’t play too, so it must have something to do with the script or model itself. I don’t think it is the script because I tested an R6 animation with another custom character and it seemed to work fine. If anyone knows a good fix to this please let me know, it is driving me crazy! lol.

Great news! I was able to fix it. It had something to do with the Root Part, I don’t know what exactly was wrong with it, but it was something with the model. I ended up messing with the HumanoidRootPart and everything seemed to work after remaking its root.

Edit: I also messed with the collisions to match a regular R6 model, so for anyone looking at this for the future… Make sure that the only parts with can collide on are the HumanoidRootPart and the Head.