New video feature doesn't work when publishing a game

Since the new video feature has been released, I wanted to put this into one of my games. But, once I published my game, and entered it, the video didn’t play. And yes, I checked the playing and looped property. But the weird thing is that, the video worked in studio but not in the final game. And also every time I publish the game and then restart studio and go into the project that I published, the playing check box is automatically unchecked. Is this a bug or am I just doing something wrong?


Thats because it’s a beta feature its not visible in game yet.

Wait, what? Then how does this game work?

That may be a gif instead of a video or it might be only rolled out into a few games at owners request.

But he’s not an intern nor a qa tester. So.

You can't upload .gif files to roblox.

You can look in the toolbox I found a dance til your dead dog in it

The videos worked for me in-game, I don’t know what is happening to you guys.

Hu that’s weird. _____________________________

He did not mean actual .gif files (or so I think…) there is an long process, a long way, to upload picture by picture video, basically uploading every 3-5 frames so you can make an “video” in studio. But I don’t think the BloxTube game uses that technique, I think there is a problem with Dogcraft_01’s Video thing, since the videos work normally for me…

Might be only for Beta Developers.

Also, people normally use spritesheets to make gifs if you don’t want to create tons of decals

There’s a topic about it, search it.

Basically, put the animation’s frames on a single image in a grid formation, then use a rapid series of translations to show only one frame at a time in sequence. This is likely what Bloxtube is doing.

1 Like

I was able to insert it in my game and I put instructions in it for how I got it to work:

I did exactly what your instructions said and it still didn’t work.

You did not do them correctly then. They worked not only for me, but for others who followed them properly. Perhaps you misinterpreted a particular instruction?

That doesn’t matter, you don’t need smart Q&A testers to test that out, that’s stupid.
It works for me fine in Studio and in-game.

Ok, I read everything correctly, I read it many times, I did it side by side, and still does not work.