Packages can freeze studio, unable to open place

From the title, I’m not 100% sure if the cause is Packages (but they seem to take a big precedent here). Whenever I enter this specific place, my studio freezes (does not unfreeze, no matter how long I wait) (See reply below Packages can freeze studio, unable to open place - #2 by TeamSwordphin). I can interact with the toolbars and drag windows. The 3D viewport is entirely frozen and cannot be interacted with. The moment I try to open any services in Explorer, my studio locks up as such:

This seems hardware-specific as some of my developers have no problem entering this place. The reason I suspect it may be package-related is that this is not the first time it happened to me. I deleted some unpublished packages a while back when I got this issue, and it solved the loading and freezing issues right away. Before, I could interact with the Explorer when I did it, but now I am entirely unable to do so.

I could possibly solve it by letting another developer delete the packages one at a time to see which one may be the culprit, but the last time we did that the freezing did not come back up, making it extremely difficult to reproduce.

As far as I know, this isn’t really a recent bug. I think the first time it happened to me was around April 30th, but the issue can be considered earlier as I haven’t opened this place for like two weeks prior to this date.

Direct Link:


  • GTX 1070 Ti
  • 32gb DDR4 3200mhz
  • Ryzen 3800x
  • Windows 10

Beta Features

  • Aerodynamics
  • Dragger QOL
  • Editables
  • Grass Length
  • New Audio API, Base Material, Studio Camera
  • Notched Screen
  • Path2D
  • Simulation Pause
  • UIList Flex
  • Updated Roblox Controls
  • Videos

I have tried with no beta features and no plugins. Team Create is on, and the place never loads if Team Create is turned off.

Expected behavior

I expect studio to open and load the place correctly, with no freezing, lock ups, or lag.

A private message is associated with this bug report


Okay, well this is peculiar. For the first time in a week, the place actually loaded, after probably 30 minutes or something. Of course, after making an official bug report but I think its relevant since this will probably happen again in the future.

When I could move around studio again, I closed it down and relaunched that exact place again. It loaded instantly. So I suspect there might be some sort of package updating issues where once it finally loaded, it no longer freezes the next time you open it.

I’ve experienced the same thing while loading places that have large packages set to auto-update and are out of date.

Something interesting I’ve found is that it only occurs when I join on my own account, which is the place and package owner. On the same PC with a different account studio loads quickly, but the packages will usually fail to auto-update.

I am usually able to get in on my own account eventually, after maybe ~3-5 minutes of freezing. Once everything is properly up to date the issue no longer occurs either.


The behavior shown in the video, and described in this thread is what would be expected when performing a large (and thus slow) package update. We are always trying to optimize package operations to run faster, and clearly we have a ways to go with package update. I will also look into improving the user experience while updates are happening, so it is more clear that an operation is in progress.

One option to mitigate the issue would be to set auto-update off for large packages, so you can control when long updates happen, instead of on open.
If you want to find the source of the update, you can compare package versions to see if there were a large number of changes added in a recent version. (Though if the update was slow, then calculating the diff could take some time.)