Part Automatically Changes Position On Run?

Hello! :wave:

I opened a blank baseplate to test something real quick. But when I run the game, the part’s position just randomly changes to

0, -340282346638528859811704183484516925440, 0

. I anchored the part and turned on cancollide and it still changes position. I even tried to add a new part. And I didn’t even touch the toolbox. What I also tried to do is that I ran the game and I pressed f to zoom to the part. And a black screen appeared. Another thing is that I tried to change the position in-game and it stays the same.

It 's really annoying so I really need help. Bye! :wave:

Oh dear that’s a long void

Where is the part first originally positioned from?

1 Like

That’s the largest value that can be stored in a 32 bit single floating point number. Are you accidentally assigning it to -math.huge?

  • 32 Bits you have 1 for the sign, 8 for the exponent and 23 for the mantisa. The largest number represented is 3.402823466E38 (from this stack answer)
1 Like

Is the part anchored? Make sure it is anchored.

Edit: Misread, do you have any scripts that could manipulate the position?

You may have a virus. Disable all plugins and try agian.

What is that though??

No I didn’t

I just added a part and it’s position was: -3, 0.5, -111

The number format used internally by the engine. The value you’re getting for that part’s Y position is literally as low as is possible within roblox. It’s probably a bug with studio.

1 Like

I fixed it. But now it’s printing 0.5, 0.5 in the output and I deleted all my scripts.