ParticleEmitter.Rate Workaround?

Apologies for the title being extraordinarily vague, but I have a game where you are placed on a turret to defeat humanoids approaching you ( During the very first bullet fire (achievable with one tap of the left mouse button), the muzzle flash doesn’t appear until the second bullet and beyond. I’ve concluded that this is due to the rate of the ParticleEmitter that creates the muzzle flash, as setting the rate to something exceedingly high makes the flash appear visually instantly upon being enabled, but I definitely wouldn’t want such a messy flash. A simple solution was to delay the firing script for a tenth of a second to enable the ParticleEmitter beforehand, but it caused the entire shot to be delayed which is definitely not favorable. Currently, I am using a BillboardGui with the same image texture as the ParticleEmitter (it looks much darker because they don’t have LightEmission properties) that is displayed upon the first shot to replace the flash that should ultimately be there. I was wondering if anyone had some cleaner workarounds instead of having to download the flash texture and visually brighten it in an image editing software. Any suggestions are profoundly appreciated!

1 Like

If you haven’t already, instead of using ParticleEmitter.Enabled, instead use ParticleEmitter:Emit()

particle:Emit(36) --36 being the number of particles spawned with this called

Thanks so much! Guess I didn’t look deep enough, sorry about that.


I forgot that even existed, excellent contribution!