Parts of viewport under workspace in view

So, i have done a little hologram system. I made a viewportframe. That moves the camera as the players camera. And put it on the entire screen with a backgroundtransparency of 1.

robloxapp-20200309-2010599.wmv (2.8 MB)

But it looks weird because the gui is always on top. Can i fix this so it looks like objects are in workspace?

Note: I know about canCollide. I just do this for fun to try and improve.

You’re running into an unsolvable limitation of ViewportFrames. Remember that a ViewportFrame is intended to be drawn on the user’s screen whereas the literal viewport (where your character exists) is in the 3D world. Guis render on top of the world; by nature of this, so does the viewport of a Gui.

You will not be able to fix this.

@Colber2677 is right.

GUIs are meant to stay on top of the screen. What you can do is use a model with CanCollide of all parts turned off.

If you need it to only show for one player, then either 1) use a localscript to add the model to workspace from like replicatedstorage, or
2) have the model in workspace with all parts transparent (and iterate over it with a localscript to make it visible)

I actually fixed this by cloning my character into the viewport frame every frame.

You might be able to do that by putting the viewport in a billboard gui