PathfindingService not creating a path when the end goal is too high

You can write your topic however you want, but you need to answer these questions:

  1. What do you want to achieve? An ability when the player click ‘T’ they move to the position of their mouse

  2. What is the issue? It works when the player clicks on the ground, but when it’s a part that’s above ground (and it has the ability to jump high enough) there’s no path

  3. What solutions have you tried so far? I’ve tried looking at other posts and checking the api but nothing has helped

here’s the script that includes the pathfinding:

Abilities.Vamp_Dash = function(Character, Position)
	local path = PathfindingService:CreatePath()
	path:ComputeAsync(Character.PrimaryPart.Position, Position)
	local waypoints = path:GetWaypoints()
	Character.Humanoid.WalkSpeed = 100
	Character.Humanoid.JumpPower = 100
	for i,waypoint in pairs(waypoints) do
		local part ="Part")
		part.Anchored = true
		part.Position = waypoint.Position
		part.CanCollide = false
		part.Size =,1,1)
		part.Parent = workspace
		if waypoint.Action == Enum.PathWaypointAction.Jump then
			Character.Humanoid.Jump = true
		if waypoint.Action == Enum.PathWaypointAction.Walk then

Figured it out, needed to set Argents

Put the solution in the dev forum qnd mark it as such please