PreloadService - Customizable way to load assets via ContentProvider [v2]

After looking into it’s is an error on my end.
For now, please replace line 104 (crtl G) of the module with this
local succ, err = pcall(function() Loader.Completed:Fire() end)
This will be fixed in 1.1.0.
Also, make sure in that script to add PS.CheckVersion() right before the loading.

Alright, Thanks.

FYI, I am looking for developers like you to join my game studio, We make games (ofc) and give away free models/scripts to help others make games like ours, I think if you joined us it would help both of us greatly :slight_smile:

Not really looking for jobs right now, but thanks for the offer! Maybe later.

The GUI does not close after finished.

Log saying finished

Yes, that’s by default. I’m going to make it a setting in 1.1, for now do:

PS.Completed.Event:Connect(function()
game.Players.LocalPlayer.DefaultUI:Destroy()
end)

I’m working on 1.1 rn, should be done later today or tomorrow.

Alright, At least you are good at responding on the devforum. Do you have discord? If so, Add me at ArtificialAI#6316 and I can help debug certain things if I come across any.

1 Like

v1.1 released! :partying_face:

What’s new?

  • More settings! Now, a total of 7.
  • Light mode UI
  • Rewrote topic
  • Major bug fixes
  • UI Fixes
  • My socials are now in a script in DefaultUI

Changes you should make:

Change your event code to this:

PS.Completed.OnClientEvent:Connect(function()
	print("Completed!")
end)

Thank you for waiting for this!

this was worth the wait. A remote event that prints “completed”. 10/10 update

1 Like

You can put whatever you want in the remote. For example, enabling/tweening UI.
Also, that wasn’t the only part of the update.

v1.1.1 Released!

What’s new?

  • Fixed Custom UI
  • Added completion time in the RemoteEvent, it’s now the first parameter.
    It’s not rounded by default, please use math.round for the exact amount!
  • “None” UI type

Changes to make:
Make your completed script like this:

local PS = require(game.ReplicatedStorage.PreloadService)

PS.Completed.OnClientEvent:Connect(function(time)
	print("Completed in "..time.." seconds!")
end)


What’s this?
image
Coming soon!

1 Like

Forgot to mention the third update, I fixed it.

I will put more updates here I guess

Coming soon!

image
My bad, i posted the wrong image lol, as i was saying, it says this after making the load function, do you know why?

1 Like

Thanks for the report! I will look into this now.

1 Like

Can I see the code where you’re firing the module?

Yeah sure, idk if im doing something wrong, but i just followed anything in the post, i tried moving it to starterplayerscripts and playergui and still says the same error
image

1 Like

Can you try again? I believe this is a 1 off issue, and I dont see a possible bug, and I cant reproduce this on my testing game.

1 Like

image
This time it showed the loading UI but after some seconds it throwed the same error again,
image
In the player it almost fully load but it did the same error, idk if im doing something wrong

Ok, I cant exactly publish this right now (because of 2.0), so:

Press Ctrl/command + F

Type
Print("Loaded "…Asset.Name)
and delete that line, it might be 117 in your script too.

1 Like

image
Still the same issue, I guess I will wait for the 2.0 version to release

1 Like