Problematic shadows with meshes, any ideas?

Hey everyone! :wave:

I’ve been putting together this one low poly map, and recently tried incorporating blender terrain into parts with this prominent issue:

  • Every time a the mesh collides with the baseplate part, a strange and quite annoying shadow crease forms around it.

Pictures:

I have tried the following to fix it, to no avail:

  • Disabling shadows locally within the meshes & globally in studio.
  • Switching the lighting technology between all 4 options.
  • Redesigning the meshes with shallower angles into the ground.

So far nothing has worked, would anybody possibly have ideas or a solution to this?

I am no builder but I do know that you can change the level type of the mesh, and use the BLOOM filter in lighting, this affects parts and meshes, you can try using this filter if it helps, I am not certain though.

It’s not an issue with either meshes or shadows, but rather, textures.

You have the mesh going inside of the other instance, which causes overlapping textures. When textures overlap, you get that effect.

1 Like

Thanks! I’ve remade the textures and it works wonderfully.

1 Like