Problems with Rope Constraints and Network Ownership

Hello! Today i was trying to fix a feature in my game, currently really glitchy, that consists on two players dragging a container using rope constraints.

However there is an issue, the movement of one of the players becomes choppy, laggy and behaves weirdly on the server due to network ownership problems.

I have tried 4 things, none of them have worked out:

  • Changing from rope to rod, didn’t expect it to fix anything and it actually did not

  • Changing Network ownership to Player1, footage here: Desktop 2023.03.28 -
    ^ I noticed that Player2’s Network Ownership changes to Player1, probably due to it being attached to the part

  • Same thing but for Player2, didn’t change a thing

  • Changing network ownership to server, made it even worse: Desktop 2023.03.28 -

I have searched and ended up finding nothing that could fix this problem. I’m not the best at working with physics :smiling_face_with_tear:, i would appreciate if someone could come up with a solution or an alternative to ropes/rods.