Reserve Server help

I’m trying to test if I’m able to reserve a server and teleport the player to it, but I keep getting this error, nothing much to talk about just simple couple lines:


function onPlayerJoined(player)
	repeat wait() until player.Character
	local rs = TeleportService:ReserveServer(7562242788)
	TeleportService:TeleportToPrivateServer(7562242788, rs, player)

The problem:


1 Like

Check if it works in roblox game client and also try to enable http requests if it is disabled.

1 Like

It still doesn’t work in roblox normal game, and HTTPs is on

player has to be an array, so do TeleportService:TeleportToPrivateServer(7562242788, rs, {player})

1 Like

That’s not the problem here at the moment, the problem is I cannot reserve a server

Are you trying to reserve a server in a place other than your own?
You can’t do that if so.

1 Like

Yes it’s mine, it’s also part of the universe

1 Like

Reserving a server is the problem, the place is part of the main place, but it just keeps saying https error

Reserved severs are a little complicated but there may be a few issues.

Cannot run teleport Because your in studio,
I have never seen the HTTP issue

Another issue might be with how you are reserving the server.

1 Like

What is the issue, I was running the game (not on studio) and it gave me the same error

Hm. To Reserve servers for me I do,

local TeleportService = game:GetService("TeleportService")

local reservedServerCode = TeleportService:ReserveServer(game.PlaceId)
TeleportService:TeleportToPrivateServer(game.PlaceId, reservedServerCode, { player })
-- Not Full code. You will need need a few changes.

You would get the same error if you are inserting a model that is private and not yours using insertservice.

So maybe it could be that the game is private?


That was the case, it works now thank you