RoadGenerator - A real-world road generator!

Did you put in your Road Data correctly?

Where road data? I downloaded it correctly.

When I exceed limit of roads I need to pay, which I hate it.

Looks cool. Ill try it i think it will help me a lot with my future game. Thank you!

Hey, really cool plug in.

My only problem that changing the size multiplier and road width values doesn’t actually change anything when I generate the roads.
Also, after generating a new road then changing the road data, it generates the previous road which is only solvable by reloading into studio.

If I do manage to change my road width to 30 studs, which is what the road plug in lane width is, what is the recommended multiplier size to fit the ratio so each block is more accurate to irl?

Thanks.

robloxapp-20200520-1439404.wmv (3.3 MB)

Script of Road Data.

local module = {RoadGenerator = require(game:GetService("ReplicatedStorage").RoadGenerator)}

I have correctly script.

You can try finding another service, that was just the easiest/best one I could find.

Where?

Earlier it worked bit and now don’t work again.

05:45:51.219 - Workspace.RoadGenerator:72: attempt to perform arithmetic (mul) on table and number

05:45:51.220 - Stack Begin

05:45:51.220 - Script ‘Workspace.RoadGenerator’, Line 72 - function genRoad

05:45:51.220 - Script ‘Workspace.RoadGenerator’, Line 135 - function generateRoads

05:45:51.221 - Script ‘rg.generateRoads(false, true, .5, 10000)’, Line 1

05:45:51.221 - Stack End

Does it work when you just run .generateRoads()?

1 Like

No, it doesnt unfortunately

sucks because it looks so good and would be so useful

Are you sure you pasted the RoadData in correctly?

This is a little confusing since it worked for others.

For me as well, I could give up on this. Generate is really good, there is another way like to make roads realistic, highways, transportations tunnels, etc?

Whoops… Is this normal? image
(edit: and this?) image

Have you made sure you pasted the data into the RoadData multi line string correctly?

local module = {}

module.Data = [[

{

“type”: “FeatureCollection”,

“name”: “roads”,

“crs”: { “type”: “name”, “properties”: { “name”: “urn:ogc:def:crs:OGC:1.3:CRS84” } },

“features”: [
– blah blah blah
]

}

]]

return module

If that’s exactly what you’re code is, then that may be the issue. There’s no data in that.

ps, to make it easier for people to read your code on the forums make sure you format it like so:

image

Ah, sorry. And where I put “blah blah blah”, that’s all my data - it’s just pretty spammy.

And you’re 100% sure you pasted the data correctly? (and didn’t change any code in the main module?)

I haven’t seen this error before.

I pasted it all correctly. If it matters, I used Atom instead of Notepad++