Roblox Building/Modeling tools getting stuck

  1. What do you want to achieve? Keep it simple and clear!

I’m trying to fix the Roblox modeling/building tools

  1. What is the issue? Include screenshots / videos if possible!

I’ve had this issue for a little while now, where the studio building tools get stuck facing a certain position and I’ve tried to find similar topics or answers to the same problem, however, I found nothing.

Here’s what I mean, the arrows are stuck in the same position despite the model being rotated:
Screenshot (15)
Screenshot (16)

Help is appreciated as this is very annoying when I’m trying to build anything in Studio.

Set the World Pivot Orientation property of the model to 0, 0, 0

Thank you, however, this didn’t change the orientation of the arrows. I’m trying to make the arrows automatically change accordingly to the orientation of the model, sorry if I wasn’t clear enough on that.

In the image below, you can see that after changing the Word Pivot Orientation the Roblox tools themselves don’t change for some reason.

When using the F3X building plugin, I believe you can swap between global and local movement, which make the arrows either face on the x, y, and z axes or in the same direction as the table.

1 Like

If the move tool’s arrows are staying at the same orientation, I have also been having this issue for about a week now. When it first happened, it just started randomly.

You could also try copying the orientation of any part on your table and pasting into the World Pivot Orientation property.

At first I thought this could have been the case because around the time of me getting the exact same issue, I had recently been playing around with FX3. But after some testing, it seems like FX3 is not at fault.

I just tried disabling the plugin, opening up a fresh studio window, and testing out the move tool, but it did not fix anything. I also tried switching between the Global and Local modes you had mentioned while the plugin was still enabled and that did not fix it either.

Try pressing ctrl + L or making the primary part something that’s facing straight.


I suppose I’ll have to start using this plugin if that’s possible because the Roblox one has been very buggy lately, so thank you.

This fixes the hitbox around the model/part(s), but the arrows still remain in a fixed position.

Oh, thank you, pressing Ctrl + L solved the issue, do you know what that shortcut does? Just curious.

It simply allows you to make the part move locally or globally.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.