Roblox Crash when I publish an animation

I recently had an issue with the Animation Editor.

I was making animations for the swords of my game, and I forgot to Set the Priority to “Action”. So, I changed the Animation Priority from “Core” to “Action”, but then, when I tried to export/publish the Animation, Roblox Crashed, and everytime that I try to do that, Roblox Crash. I would want to know how to solve this.

I tried the next things :

  • Leave and Join Roblox Studio.
  • Look at the Plugins Folder.
  • Creating a Custom Humanoid (Without using the Default Rig Builder) to animate it.
  • Uninstall and Install Roblox Studio.

And anything worked…

I found this Error in the Output when I generated the R15 Humanoid


Few questions;

  1. What version of Roblox Studio are you running?
  2. Have you made sure the Animation Editor is up to date?
  3. What OS are you using?
  4. Do you have a place file that you can consistently reproduce this on for us to try to repro the crash?
1 Like

You didn’t mention if you restarted your PC

1 Like
  • Im using the Last Version of Roblox Studio
  • Yes, my Animation Editor is up to date
  • My OS is Windows 10
  • I dont have a Place file :confused:

Yes I restarted my PC, that didn’t work

1 Like

Looks like a bug more than anything.

cc @greywolf_sif

1 Like

Thanks for bringing this to my attention. Can you tell me exactly when the crash happened? You went to File -> Export in the Animation Editor and then did the export window pop up and were you able to do anything in that window before the crash happened? Also, is this happening for you consistently?

Also the Error in your output seems unrelated. I will dig into the cause but after an initial investigation it appears that the error shouldn’t block you from creating a rig.


As you can see in the image, the Export Window pop up, and usually the upload reach the 5% - 14% Completed. Everything is so fast and I dont have time to interact with anything.

And this happens to me consistently, I tried to make new animations instead of editing the existing animations, but this didnt work.


The problems seems to be related with my PC/Plugins and not with my User or the Studio.

(It isnt solved)



Now, when I try to open the Animatons Editor, the Output gives me this error.