Roblox Studio not saving current layout

I’m having a problem with Roblox Studio. Whenever I open a place, the toolbox and terrain editor open up as well. How do I fix this?

I have deleted the registry entries in Current User → Software → Roblox → Roblox Studio and it does not fix the problem. It’s almost like it has been saved to the place and I’m unable to clear it.

1 Like

This problem can be caused due to a large number of add-ons such as plugins, etc., I have the same problem and not only that, most often, reinstalling roblox studio helps me personally, you’re can remove that at here (Remove that at BuiltInPlugins)

Interesting. I don’t have a lot of plugins, and I keep them all disabled until I need to use them. I haven’t tried to reinstall it yet, but that is on my list of things to try.

Most likely, this is really a roblox studio error.

Well, now the problem has changed. It’s not opening up the terrain editor or toolbox anymore, but now it won’t open the output window or the command bar when a place loads. I’m telling you I cannot win. LOL.

I think Studio is having a nervous breakdown.

You have removed the Terrain plugin from the “BuiltinPlugin” folder - this is one reason why they do not open, If you want, you can download the plugin or buy its name “Part To Terrain”, “Terrain Generator” until these problems are solved, most likely, no one else will be able to help

I haven’t removed the terrain editor because I can still open it when I need to. I’ll just have to deal with it.

If so, then the topic is closed.


The problem came back. It is definitely an issue with data saved to the Registry. The key is HKCU\Software\Roblox\RobloxStudio. That’s where Roblox saves a good chunk of it’s data.

And with that, I have found something interesting though. If you save your place to Roblox while the test server is running, it seems to save the layout correctly. I have no idea why. I’m still trying to identify which registry keys are involved in the layout. It’s not really obvious by the names. There’s a number of values in several keys that deal with metrics, so I have to wonder if it’s one of those.