Scripts do not work when transferred to another game, no matter what is done

  1. What do you want to achieve?
    I want the scripts I made to work in a game I have spent hours making.

  2. What is the issue?
    The scripts. No matter what they do, they will simply not work. No errors, no glitches, just no function whatsoever. They worked in the baseplate I created great, but when I transferred them to the game they simply stopped working with no cause or explanation.

  3. What solutions have you tried so far?
    Please correct me and post the link if I’m wrong, but I haven’t found anyone else having this problem. I checked all the names, capitalization, and the Output but haven’t found anything. They stopped working today, the days before the scripts I imported worked great.

I should probably include that the game I’m importing them into is a group game, and the baseplate is my own. Would that affect anything?

1 Like

It might be possible other scripts are interfering? Try putting a few prints statements in areas of the code that should be running and you might be able to figure out what the issue is.

Thank you for the feedback. I put print functions in the code, and they did not run. I checked every script in the game and checked if it was interfering. Alas, it seems none of them were interfering. I’m now more stuck and frustrated then ever.

Try going back in your Version History , to the version of the game where it was working fine

What do the scripts do? I had this issue before, it was a simple fix for me though.

They change the brightness, atmosphere density, and change several part’s transparency.