Scripts works in studio but not in the game

Hi I am trying to make a server sided coin collecting system, which saves the coin collected data onto the server, so far it was hard, and all the testing was done in studio, but when I went to test the game with a friend on the ROBLOX website, almost none of the scripts worked there.
Just to let you know I searched on the internet for an answer, and I could not find one

  • I published the game. The error has nothing to do with not publishing the game, please don’t say I should publish the game again cause it does nothing for me
  • The commit button in the script editor is grayed out and clicking on it does not do commit when I click on it.
  • There is no draft button in the view section of studio
  • I never turned on team create until I finished the scripting
  • The game is a group game
  • The game includes :FireServer() commands and :FireClient() commands, and all of the events are stored in replicated storage
  • no errors, or things I don’t want in the game are in the code
  • I used the publish game as feature and nothing happened
  • also don’t click the button while testing the game, I am using it to test a feature which is relatively… unfinished

Heres the game, its uncopylocked so that you can easily open it up in studio and see whats up. I don’t have a problem with giving it away to the public cause I was planning to open-source it anyway when I finish and also cause its broken, only in the client, the code may be a bit messy


Um, so I tried it in studio, and it was very confusing. One script errored saying “madgod661 is not a valid member of players.” I have no idea what the button does. There were two parts, and when I touched each of them, they disappeared and didn’t respawn. All this was in studio.

oh I was just using it to test it on madgod661 in the game, srry, just dont click the button.

oh ok. But are the parts supposed to respawn? Because there were only two, and they didn’t.

It’s definitely a studio bug, there’s no malicious codes or some sort.

If your toolbox doesn’t appear but it’s turned on or if you can’t select any objects, then that’s what is causing it. You must save and publish when your toolbox is fully functioning or some other stuff is causing it.

hmm it may be because of the result of an error, the button was created for the sole purpose of testing a feature where you could see the coins a player who is not you hasn’t collected

I’m not getting any other errors except for maddog

Oh yeah, i just encountered that bug. I couldn’t turn on toolbox and my mouse was set to the roblox cursor.

It is a common bug, you should probably make a topic about it but anyways i think that is what is causing it.

Hmm maybe this could be a result of a bug, but this topic will remain unsolved until someone says a solution that works, or confirms this is a bug. Or sends me the place file but working.
So now I will continue waiting for an answer

I also encounted that bug before, but I couldn’t move parts without building plugins, and I use F3X regularly while building, reinstalling roblox studio seemed to fix it, but I don’t think it fixed the cursor, so I think it is an update.

There is still no solution, does anyone have an idea of what is going on? Or is it a bug.