Sections of the Catalog API no longer work or changed

I know that this is probably not the most suitable category for this post but unfortunately I cannot write in the #bug-reports category.

I don’t know if it is exactly a bug or the API just changed, but some categories of my game catalog (avatar editor game) suddenly stopped working (they worked correctly and there were no scripts changes)

One of the many sections of the catalog that no longer work is that of accessories, hats:

https://catalog.roblox.com/v1/search/items/details?SortAggregation=AllTime&SortType=Relevance&SubCategory=Hats&Category=Accessories&IncludeNotForSale=true&Limit=30
This request has always returned all objects correctly, while now it returns this:
{"errors":[{"code":1,"message":"Category subcategory selection not supported.","userFacingMessage":"Something went wrong"}]}

Also this completely destroys my proxy server system which changes host when the message “errors” arrives (to prevent few errors i had)…

If anyone knows how I can fix this situation as soon as possible I would be happy, thanks.

Sorry for the english.

1 Like

There is nothing wrong with the API endpoint. SortAggregation, SortType, Category and Subcategory all require a number corresponding to the desired option(s), not the name. You can visit the documentation of the Catalog API that has the information on how to use the endpoint and all of the options.

Here is what your request url should be:
https://catalog.roblox.com/v1/search/items/details?SortType=0&Limit=30&Category=11&Subcategory=54&IncludeNotForSale=true&SortAggregation=5

1 Like

As I said it worked very well with words too, I will try to replace the whole system with numbers, I’ll let you know if that’s the solution, thank you for your help!

Just one question, why did you put 54 as a subcategory? it tells me hats is 9, but it doesn’t work, also there is no 54 in the list … where did you get it from?

image

Ty for helping me

The catalog api’s url’s format bears the same structure as the actual catalog’s and when going to the catalog page, there’s no subcategory named “Hats” under the Accessories category anymore. These are now under the head subcategory which has been assigned the number 54

Catalog - Roblox ← Link to the hats page for catalog (you will see that the Subcategory is 54)

4 Likes

How would I go about getting the page number?

Edit:

So I found a way to do this. When you get the JSON data there’s 2 variables from the response.

There’s

  1. previousPageCursor
  2. nextPageCursor

So what you need to do is use the link and add this to the end
&Cursor=previousPageCursor – or whatever cursor you are using.

You know you’re on page 1 if the previousPageCursor is null.