Set the focus to the chosen object after Ctrl+P

After choosing an object with Quick Open (Ctrl+P), the focus is not being set to it in the Explorer Window.
So I have to use the mouse to activate this object and be able to navigate in the explorer window with the keyboard:

Repro

  1. Open any project, or create a new empty project
  2. Press Ctrl+P
  3. Chose any object and press Enter
  4. The object will appear as selected in the Explorer window but to be able to use it or navigate in the explorer window, I have to click on it first.
4 Likes

Confirmed, the Explorer is not focused at all after Quick Open is used.
I had similar results using the Explorer Filter shortcut and then Quick Open. Explorer Filter continues to be focused even when the game view isn’t focused. Focusing the Explorer and then using Quick Open works because Explorer is already focused in the first place.

Hey @rogeriodec_games, thank you for bringing this up! Do you find it useful when the focus shift to the Script Editor when opening a Script or do you think opening a Script should also focus on the Explorer? I see your point with 3D objects though.

3 Likes

Since I don’t use Studio’s native script editor, I didn’t notice that.
However, I think the solution to cover both cases is simple:

  1. When selecting an object through Quick Open, if it is a script, focus on the script; if it’s any other object, focus on the explorer.
  2. Or, if you want to be more flexible, create a parameter in the Studio settings where the user can decide this.

This issue should now be resolved! If this issue is still occurring, please create a new topic for us to look into.

2 Likes

This topic was automatically closed after 5 days. New replies are no longer allowed.