Shadow Issues in FIB

Is this a normal shading thing with the Studio Engine? I can’t get this to look right.

I’m trying to fix this shadow issue, and no matter what I do, it still appears that this half of the area isn’t shading. I’m using the Future lighting settings.

I’ve tried to rescale and add more parts in the general area, but it seems to act as if it’s not getting any shadow effects at all.

Edit: I didn’t rescale the long piece above it back a bit, it fixed, but now I’m sitting here with a crick in my neck over the fact that larger parts don’t receive enough shading as smaller parts.