SmoothPlastic collide glitch


#1

Hello Developers,
I have started to notice that ‘SmoothPlastic’ shows up when it is overlapped, it never did this before and I have only recently noticed this.
Basically the SmoothPlastic is Z-Fighting which it has never been doing before. I assume it is due to the updates roblox has been releasing which makes the parts reflect the sun more causing the bricks to Z-Fight as they overlap.

The only fix I have found for this problem currently is union together all the parts that overlap each other. Maybe this might be due to the lighting or just a general Roblox update.
My main question is what is causing this problem?
My initial thoughts are that it is either:-

  • Roblox update
  • Lighting problem
  • Colour of the brick

If anyone can help me out that would be great, Thanks!


#2

Can confirm this has also started happening for me.

I don’t think its a colour issue as have tried two different colours, though on some colours it is much more discreet. I believe its most likely a lighting issue.


#3

I believe it is, I think it is more to do with the lighting update in general, as Roblox improved the reflection of the sun to the part so it makes the collided parts mess up as they are all inside of each other. Though I will look around the forums now to see if anyone has an answer to this.


#4

Is this occasionally for you or permanently? I have had times where its fine and others when its not.

On another note, I unioned the pieces then seperating them and it seemed to fix it, though that might only be a temporary fix.


#5

Yes, I occasionally had this problem for some reason, I also unioned it myself and it fixed it.


#6

I made a mistake in the typing sorry my bad.

I wouldn’t recommend using unions as the solution as the triangles makes it harder to load and can cause lag.

But as I said perhaps try unioning and then seperating, which did the trick for me, although that might just be temporary.

For now I am also using unions, hope this issue is fixed (and perhaps ask for it to be moved to bugs)


#7

Possibly a solution, though it would be temporary, like I said I will do more digging on this issue in general to see what is actually causing it, though I assume it is the reflections.


#8

If you find anything be sure to let me know!


#9

I will do!


#10

Current solution to this issue is unioning the parts then separating them, though I assume it is temporary. But this is the best working solution so far to fixing this issue.


#11

I’m unsure what’s the issue. All I see on the image is a whole lot of Z-fighting.
Do you want to get rid of Z-fighting or…?


#12

Pretty much, but I am confused why it is happening in the first place as smooth plastic has never had Z-Fighting


#13

It doesn’t matter what material you use. If two surfaces are placed on the same plane, Z-fighting will occur.
Sometimes the difference in placement is big enough that it looks like it’s not Z-fighting, but small enough for it to appear if you zoom out your camera.
I’m not sure about this one, but it may also depend on your quality settings, and platform you’re using.


#14

Carrying on with @Veldaren. I had an issue with two parts colliding with each other on lower graphic settings


#15

Completely correct, I have always worked with top graphics turned on, so I have never noticed this, went onto the game and realised my graphics was lowered, that was the issue, turned it up and it looks like this


I feel like the only solution to this is to union all the parts together currently. Worked for me when I did that anyway, one thing I have learnt though from this is that Z-Fighting can occur on any material, I did not realise that so thank you.


#16

A potential fix to this problem without unioning them all together (which can cause alot of lag) is going into properties, and off-setting each part a small degree more or less, for example changing the Z-plane from 1 to 1.001. This will eliminate Z-fighting and is hard to notice.


#17

Will take me a long amount of time to do that but still the best solution on this topic so far!


#18

A small offset will eliminate the actual z-fighting, but on lower graphics quality settings you will still see a hard transition between the parts. Their surfaces not having nice color continuity across the intersection isn’t from the z-fighting, it’s from the lower-quality implementation of specular highlights which does not use the depth buffer for nice per-pixel gradations. You don’t see the z-fighting on higher quality levels because the fight is between same-color pixels.


#19

Still, the best way to get rid of Z-fighting is to actually get rid of the surfaces, so there’s only one surface left. And where is only one surface, it’s impossible for Z-fighting to occur.

I’m not sure what your land is made of, but it’s flat enough that I’d personally consider exporting it into Blender and turning it all into one MeshPart (if you don’t want the character to be floating above the “sand” areas, you can split the mesh into grass and sand, and then export those as separate meshes). Once you clean it all up, you will get rid of tons of unnecessary faces, and will have no Z-fighting issues at all. Just remember to export at 0.01 scale in Blender so it’s all the same size once you import it to Roblox.