Starter characting not working?

(this is a repost because i posted this in like the middle of the night and only 1 person answered)

  1. What do you want to achieve? I want to make this starter character work and use tools!!!

  2. What is the issue? The issue is that for some reason it won’t let me use tools and it moves kinda weirdly

  3. What solutions have you tried so far? I’ve tried re-rigging it like 100 times but still doesn’t work, I’ve also looked on the dev forum.

Here are some images:

(what it contains)
Screen Shot 2021-11-25 at 8.58.21 PM

(what its like ingame)
Screen Shot 2021-11-25 at 9.00.00 PM

(using a tool with custom character)
Screen Shot 2021-11-25 at 9.00.23 PM

(how the tool SHOULD look like with the custom character)

pls, help ):

You are going to have to be a lot more specific with your information.

You first show 2 pics of a green character and in your Workspace screenshot which is an R6 character with and without the tool selected. Then you show your R15 character in the last image with the applecore tool highlighted and 4 GUI arrows above it.

I don’t think it’s a character rigging issue and that’s where you seem to be focusing your attention. Player ‘movement’ is how the player goes from one place to another in the game. Animations are how the player is animated (arms, legs, head etc.) in the game.
If it is the animation you are talking about then the difference between the R6 and R15 avatars is probably your issue.

Also it appears you are using a free model tool made by CarSiewGuy. Why not try getting in touch with them? If the applecore tool is designed to move the player then it likely has something to do with your issue.

We can’t figure out what’s working when you don’t provide scripts or anything other than a screenshot of the StarterCharacter in the Workspace window and some vague pictures of what’s happening without a real explanation of what’s going on.

to clarify, the applecore tool is for animations (pressing up key plays up animation and stuff) and there has been no information on how to contact CarSiewGuy.

and basically, the problem is about how my custom starter character isn’t able to use tools properly (as shown in the screenshots) The custom character is supposed to equip the tool and show the GUI but for some reason, it doesn’t. It also doesn’t move for some reason and just stays put there (all parts are unanchored) There is no use of any scripts inside of the model.

1 Like

So what does this have to do with the “Art Design Support” category?

So basically this model:

[ANIMATABLE] AppleCore Bandu - Roblox

What experience do you have with animations, tools, and custom character rigging?

Since you have issues with the tools did you look into the tool settings or scripts?
There has to be a script somewhere to get the inputs from clicking the arrows to play the animations.
If you made the animations are you sure they work properly?

The fact that you are just giving us bare basics for information and that you’ve posted in the wrong category makes it seem like you’ve got this free model and can’t make it work for you so you are asking us to fix it.

Are you sure this applecore tool/model whatever is designed for use with custom characters?

fixed it by re-rigging the model and deleting some parts

1 Like