Stop button crashes Studio on macOS Mojave with a local file

On this one file, about 90% of the time, clicking the Stop button tends to freeze Studio indefinitely (not every time, but most of the time). I have to save my file, click Play Solo, do my testing thing and then click the Stop button. If it works, yay, I keep going. If it freezes I have to terminate Studio forcefully and restart it. Nearly every single time. It’s really, really annoying.

Extra details:

  • I’m editing a local file (not a published game)
    • The issue doesn’t seem to occur on an empty baseplate. I have no proof of it happening, but there’s no way to completely rule it out since the issue doesn’t happen 100% of the time
    • There is no BindToClose, I searched the forum and it’s not my issue
    • The issue turned up after the update, with no modifications to my code, it worked before
  • I’m running macOS Mojave 10.14.3
    • 15" MacBook Pro, mid-2015, got it repaired about a week ago so it’s (probably) not my hardware
  • The issue happens after the latest Studio update (never had it before)
    • Precise Studio version is 0.374.0.282978
    • I don’t know the previous version that worked

AMA, I really want to solve this

1 Like

I accidentally left a place running for about 2 hours earlier, and when I clicked Stop it froze Studio again.

Now Studio can’t open any autosaves or even published games without crashing.


Here’s the log from the terminal when I try to open a local file, if that helps

1553547510.24712,61455c0,6 Info: GamesPageController::onGameClicked(0)
1553547510.24732,61455c0,6 Info: RobloxMainWindow::createAndShowIDEDoc with task EditFile
1553547510.40790,61455c0,6 Info: RobloxIDEDoc::open - start
1553547510.41237,61455c0,6 Info: 	Locking DataModel
1553547510.42214,61455c0,6 Info: 	Initializing Ogre
1553547510.42239,61455c0,6 Info: 	Initializing View
1553547510.42754,61455c0,6 Metal renderer: AMD Radeon R9 M370X
1553547510.42758,61455c0,6 Caps: ThreadSafe 1 Framebuffer 1 Shaders 1 Compute 1 Instancing 1 ConstBuffers 1
1553547510.42760,61455c0,6 Caps: Framebuffer: MRT 4 MSAA 8 Stencil 1
1553547510.42761,61455c0,6 Caps: Framebuffer: Depth16 1 Depth24 1 DepthFloat 1
1553547510.42762,61455c0,6 Caps: Texture: RGB10A2 1 RG11B10F 1
1553547510.42763,61455c0,6 Caps: Texture: DXT 1 PVR 0 ETC1 0 ETC2 0 Half 1
1553547510.42764,61455c0,6 Caps: Texture: 3D 1 Array 1 Depth 1 MSAA 1
1553547510.42765,61455c0,6 Caps: Texture: NPOT 1 PartialMips 1 CubeMipGen 1, CubeFramebuffer 1
1553547510.42766,61455c0,6 Caps: Texture: Size 4096 Units 16
1553547510.42767,61455c0,6 Caps: ConstantBufferSize 65536
1553547510.42768,61455c0,6 Caps: 32bIdx 1
1553547510.42769,61455c0,6 Caps: ColorBGR 0 HalfPixelOffset 0 RTFlip 0 MinusOneToOneDepth 0
1553547510.42912,61455c0,6 Metal: creating framebuffer 1280x960
1553547510.42916,61455c0,6 Video memory size: 2147483648
1553547510.43965,61455c0,6 Loaded 1025 shaders from pack metal_osx variant FFlagExtendedHdrPrecision (3296377 bytes)
1553547510.43971,61455c0,6 Compiled 205 shaders in 10 ms
libpng warning: iCCP: known incorrect sRGB profile
1553547510.54095,61455c0,6 Info: 	Initializing Explorer
1553547510.54102,61455c0,6 Info: 		RobloxViewStudio::RobloxViewStudio - start
1553547510.54103,61455c0,6 Info: 			Marshaller
1553547510.54105,61455c0,6 Info: 			BindToWorkspace
1553547510.54111,61455c0,6 Info: 		RobloxView::RobloxView - end
1553547510.54113,61455c0,6 Info: 		RenderScheduler::RenderScheduler - start
1553547510.54114,61455c0,6 Info: 			Marshaller
1553547510.54116,61455c0,6 Info: 			BindToWorkspace
1553547510.67533,61455c0,6 Info: 			ConfigureStats
1553547510.67554,61455c0,6 Info: 			RenderJobCyclic
1553547510.80773,61455c0,6 Info: 	Loading File : /Users/LoganDark/Documents/Roblox/AutoSaves/Place_AutoSave_25.rbxl
1553547511.02725,61455c0,6 Metal: creating framebuffer 558x1486
1553547511.02733,61455c0,6 Metal: creating framebuffer 558x1486
1553547511.12359,61455c0,6 Info: 	Initializing Terrain
1553547511.12364,61455c0,6 Info: 	Initializing Undo
1553547511.13914,61455c0,6 Info: 	Open Success
1553547511.15942,61455c0,6 Info: RobloxIDEDoc::openPlaceSessionConfigWithStream - end
1553547511.19024,61455c0,6 Info: RobloxIDEDoc::activate - start
1553547511.19381,61455c0,6 Info: RobloxMainWindow::showTabWidgets

And when I try to open a published game, it’s pretty much the same but with

1553547638.39624,fc595c0,6 Metal: resizing main framebuffer to 1806x1016
1553547638.57898,fc595c0,6 Metal: creating framebuffer 1280x960
1553547638.57907,fc595c0,6 Metal: creating framebuffer 1280x960
1553547638.71723,34a2000,6 Info: DataModel Loading[censored]

at the end.

Okay, I figured out a workaround to my previous post.

Open an empty Baseplate, close the tab (not Studio) and then open whatever file you want to open.

Worked like a charm.

…Or not?

But sending Studio Ctrl+C makes it do something.

Sending it SIGTERM in an infinite loop makes the UI semi-functional as long as the loop runs, but the viewport doesn’t work (not even selecting parts) and trying to expand anything in the explorer makes Studio freeze despite the signals.

while true; do killall RobloxStudio; test $? -gt 128 && break; done

SIGKILL was required to stop Studio after trying to use the explorer.