Streaming Parts Bug with Terrain

I decided to implement Terrain Water into my Catching Fire Game for realism and such. After testing it in Edit/Solo it worked fine so I shutdown my servers to see players reaction to it. As I entered the Arena this is what I recieved:

I tried a ton of stuff, and finally with nothing left to try my friend suggested turning Streaming Parts off, and afterso I got the correct result:

To fill out the whole ‘Bug Report’ Questionare;

  1. The Bug happens 100% of the time. I tried everything to get around it, and it wasn’t working.
  2. I produced it by having Streaming Parts on, and Generating a large piece of terrain with the following:

function createWater() game.Workspace.Terrain:SetCells(,1,-100),,1,100)),"Sand","Solid",0) game.Workspace.Terrain:SetCells(,2,-100),,3,100)),"Water","Solid",0) end
3. The Bug happens on the actual site ( in ONLINE Mode.
4. I haven’t tried it in other levels, but I would assume so as there isn’t anything specific about my game.
5. Screenshots above.
6. Not a Graphics Bug.
7. Just implemented this, definitely has something to do with Streaming Parts.

My username is SmoothBlockModel

This is really helpful, I’ll try to get one of the streaming guys to take a look.


Oh my Dream Hat. Glad to help @John

Does any Mod/Admin know if its been fixed yet?

I really need to re-add Streaming to my game, its a lag fest without it.

We will look into it soon. Unfortunately due to holidays the patch releases will be limited so you might not be able to see the fix before new year…

We have fixed this bug. We can probably make it live within a few weeks. Stay tuned.

Iv been experiencing the same with with personal servers. When you make terrain 3D with stamp tool.

1 Like

So with the new Terrain Update I thought I’d see if it was fixed – still happening.

Any update on this?

EDIT: Just read xshens reply, Sorry about that. Thank you!

The bug fix has been released. Please verify.