Studio DataStore is broken again (changes made to a DataStore don't replicate to the other)

-> Change a DataStore while in Online mode
-> Can’t access that from Studio


-> Change a DataStore while in Studio Test Server
-> Can’t access that from Online mode

Yes, game:SetPlaceId(4008009) was used.
Yes, saving API was checked:

More discussion and repro code:

Trying to access people’s DataStore saves while I’m in Studio isn’t working. That’s supposed to work. ):


Totally guessing here, but try calling DataModel.SetUniverseId instead of SetPlaceId.

Tried game:SetUniverseId(64030455) and game:SetPlaceId(487805) in the command bar, and in test server it doesn’t change anything - studio still thinks my online-saved datastores are missing

When did this start happening to you?

4 days ago (about Thursday night) is when I really tried to use process of elimination to figure out I couldn’t access people’s online datastores from within studio’s server mode. (And vice versa: couldn’t access datastore changes made from within studio, while online)

Data Stores can be tested in a local server. Take care though, as this doesn’t work directly. Make sure that:

You are logged in
You are testing the game on Test Server (Play Solo does not work!)
You have either opened the game you want to test with Edit Mode, or you have set the PlaceId manual to the place you are editing with the SetPlaceId method.
Note: Data you save is actually saved on the servers on ROBLOX. It’s highly advised to create a separate test place or to backup data.[/quote]

I thought I might have misread that but the note confirms something’s not matching up. I’ll keep trying in the meantime and will edit this post.

Also, the wiki article is missing the “Enable studio access to API services” from the Develop tab on the site (picture in original post)

Yeah I cri that it doesn’t work :c

I think we figured it out, should be fixed on Monday day! Sorry for the inconvenience, gents!

@Woesus Given that you experienced this issue 5 years later, it may be a different bug altogether. Can you file a bug report with details?