Studio frozen after bringing a minimized window into focus

#1

Edit: update from a year later. Studio is still freezing every time I bring an out-of-focus studio window back into focus after an hour. Sometimes it takes 10 seconds, sometimes its permanently frozen. Can we get a switch to disable this unloading functionality? I don’t need the extra memory…

Whenever you minimize a studio tab, it appears to save the frame that was last rendered and then completely unloads everything to save resources.

However this poses an issue for places like this:

It often takes around 10 seconds (sometimes more!) to re-load this place. During that time studio completely freezes up. This happens every time I minimize studio and bring it back to focus. Since I’m constantly switching between studio windows, this is a massive hindrance for me and is incredibly annoying.

Here’s me waiting 30 seconds to access a studio file that was already open, just minimized:

I can handle rendering windows that aren’t open. I can’t handle waiting every time i switch windows.

Thanks!

21 Likes
Studio will hard crash at random when regaining focus
#2

Is this a laptop?

1 Like
#3

It’s a desktop with a GTX 1080ti and an i7 8700K

4 Likes
#4

What do you have selected for GraphicsMode in Rendering options?

1 Like
#5

I have it set to max settings. I beleive 21. I use studio very frequently to take screenshots and I need the screenshots to be crisp

1 Like
#6

No, I’m asking about GraphicsMode. D3D9/11/GL/Vulkan?

1 Like
#7

Oh, not sure. I never changed that setting so it should be set to the default option for a nvidia gpu and intel cpu on Windows 10.

I’m away from home and can’t check right now

2 Likes
#8

image

1 Like
#9

This happens for 5-10 seconds every time I open a big studio place that has been minimized for a bit…

Screenshot_81

1 Like
#10

Here’s me waiting 30+ seconds for studio to unfreeze after opening a minimized studio place

1 Like
#11

Try setting your GraphicsMode to something like D3D11 or Vulkan.

Automatic has always posed some weird bugs for me.

Wouldn’t hurt to see if changing your GraphicsMode solves the problem! :slight_smile:

2 Likes
#12

@Nightgaladeld I just had to wait four minutes for a minimized studio window to open. This happens every single time I open a minimized studio window. It’s horrible. Please make sure someone sees this

1 Like
#13

Has been happening for me for months now. If the place is massive, it will never respond again after being minimized.

2 Likes
#14

I didn’t build a top of the line workstation to have to spend ten minutes waiting for Roblox Studio to come back to life every time I leave my computer for over an hour.

Either fix this issue or give us an option to disable unloading

4 Likes
#15

I honestly thought this was an issue with my computer and not Roblox Studio. I also have a relatively high-tier rig and use similar settings as @berezaa.

I experience this a lot, especially when I go away from studio to create assets in Photoshop/Illustrator. Sometimes it doesn’t even unfreeze - I always suspected it was due to my high usage of Packages and LinkedSources.

1 Like
split this topic #16

A post was merged into an existing topic: Clutter posts

#18

This is a bug, and not a feature. As far as we were aware, this had been fixed. We patched one way this could occur a few weeks ago. But if you are still encountering this in the latest version of Studio, it seems there are more ways for this to happen, or the original fix isn’t working.

First, can you verify the fix is enabled? print(settings():GetFFlag("HttpTcpKeepalive")) should log true to the output. If this is enabled, we need to determine whether this is a separate issue with the same outcome, or the same issue and the previous fix is not working. To start off (also @cloakedyoshi), is this still happening with every place you have open (even empty baseplates), or just specific places?

#19

Had to do some testing, it’s any game I leave open and then go AFK. If it doesn’t freeze when I return, it freezes when I close the file.

#20

Once you find Studio freeze for any suspicious reason, please generate a few full dump (maybe one dump per minute :slight_smile:), zip & upload to google drive, then PM me the shared link to download. It would be better if you can save 2 or 3 dump files, for instance, one dump per half minute:-)

https://support.microsoft.com/en-us/help/931673/how-to-create-a-user-mode-process-dump-file-in-windows

1 Like
#21

HttpTcpKeepalive is set to true in my settings. I am currently out of office and not on my main device though. If the issue persists, I’ll check again.