Suddenly all my scripting is failing?

  1. What do you want to achieve?
    A game that works.

  2. What is the issue?
    My game is suddenly working perfectly fine in studio (I didn’t publish the update yet), but in the actual game :SetPrimaryPartCFrame on an NPC isn’t working. My intro gui that sets the camera to scriptable is failing. I don’t understand why is only works in studio.

  3. What solutions have you tried so far?
    I don’t know.

Try going to the game settings in-game and looking at the Developer Console. If you do that you might be able to see an output error.

  • Make sure you have :WaitForChild("") and add some delay before targeting any part of NPC.

  • This happens because the script loads faster than the part and bugs out.

It should work. If not, please reply with full information. :grinning:

Does it have the primary part as humanoidrootpart?

It was working an hour before, it was working for days before suddenly (I didn’t touch the scripts), it stopped working.

One time, this exact same thing happened to me so I just clicked “drafts” and committed every script then it worked.

I don’t understand how it worked but it did.