SurfaceGuis affected by ColorCorrectionEffect but only if AlwaysOnTop is false

SurfaceGuis are affected by ColorCorrection, but only when AlwaysOnTop is set to false. I would expect it to never be affected under any circumstances. Turning up or down LightInfluence is not able to solve this issue. It is a consistent bug on all places. This bug makes me unable to display 3D objects in a GUI with the same ColorCorrectionEffect as the rest of the game.

Repro file:
surfacegui repro.rbxl (21.6 KB)

Repro steps:

  • Go to Lighting and enable ColorCorrection.
  • Observe how the colors of the SurfaceGui get brighter.
  • Enable AlwaysOnTop in the SurfaceGui. Notice how the colors change back to how it looked before enabling ColorCorrection.

This is not a bug but instead intended behavior due to how post processing effects are rendered on Roblox. All post processing effects are applied to the frame after all world geometry has rendered, but before 2D UI is pasted on top. By enabling “AlwaysOnTop” the engine moves the rendering of the SurfaceGui to that second 2D UI render phase and thus avoids the post processing effect.

If you want that behavior to change I would suggest creating a topic in Feature Requests.

1 Like